How to use fcitx on gnome?

#1

How to change the input method on gnome on wayland to fcitx while the default is ibus? I have searched for a long time but failed.
What’s more terrible is that I cannot even make ibus work properly in any application but gnome-shell(more exactly, the search bar on the top of the “activities” window of gnome), so I can only ask for help here using English.
Anyone can help?
:cry:

#2

如果要用ibus,可以把 /etc/X11/xim.d/zh_CN/ 下的 40-ibus 改成 20-ibus,只要前缀数字比fcitx 的小就行。

如果用fcitx,那就不要用 wayland 了

#3

https://wiki.archlinux.org/index.php/Fcitx_(简体中文)#Gnome_On_Wayland_用户无法使用_fcitx

看到这里有解决的办法!

#4

However, when I was using KDE (on wayland) and followed the solution in arch wiki(the same as provided above), I could use fcitx without any problem.
Probably due to my humble wordings in the previous post, I should emphasize that what I’m really interesting about is How to change the input method from ibus to fcitx in GNOME. I cannot find some place to change it (e.g., in gnome-control, I can only add an ibus input method).
Some years ago, when I was using ubuntu, there is a standalone setting named something like ‘input method setting’ in which you can choose which input method framework to use, but I failed to find an equivalence on openSUSE.

Anyway, thanks!:slightly_smiling_face:

#5

ubuntu确实有这个功能,openSUSE好像默认就是fcitx。

https://bbs.archlinuxcn.org/viewtopic.php?id=4552

这里看到的帖子,最新的回复是去年的。

#6

openSUSE好像默认就是fcitx。

Really? The locale I choose is en_US.UTF-8, maybe due to this the default on my system isn’t set to fcitx?

Let me check the arch forum page.

#7

Ubuntu 的 imswitch 是要重启的…openSUSE 改 /etc/X11/xim.d 下的软链接也是要重启…实质是一样的。