昨夜升级nvidia一个什么东西 进不了图形界面 现在连grub都毁了


#242

网关信息昨天就拿到了 刚才做的这一切都是基于昨天的成功经验


#243

貌似连上了?,你换个tty,dhc然后tab运行一下?


#244

你现在按 ctrl + c 杀掉,再加 -B 执行。

要多用 ps -A | grep wpa_supplicant 查看,wpa_supplicant 不能同时运行多个,要是有一个以上就要都杀掉重来。

你刚才连 wifi 都没连上,设置 dns 地址什么都是没有用的。现在应该可以了。ip a 和 ip route show 看下。要跟以前一样的话,现在应该能 ping 通了


#245

这是 rescue,好像没法换 tty。另外看楼主的发帖时间似乎不在国内。


openSUSE diagnose
#246


奇了怪了 一开始ping不通的时候也就只有一个进程,后来尝试了各种办法 才增加到三个的


#247

你现在运行下那个 ip route add default via 192.168.0.1 的命令。然后 ping google.com


#248

额,没注意到,正好看到帖子,献丑了


#249

哪的话?非常感谢你老热情出手相助!


#250

怎么回事 怎么这次就可以了 我没做别的呀?
总结一把:

退出chroot 执行
wpa_passphrase SBG6700AC-82E60-5G 密码 > wpa.conf
wpa_supplicant -B -Dwext -iwlan0 -c./wpa.conf

ip a add 192.168.0.190/255.255.255.0 dev wlan0
ip route add default via 192.168.0.1
echo ‘nameserver 8.8.8.8’ > /etc/resolv.conf
echo ‘nameserver 8.8.4.4’ >> /etc/resolv.conf 这里 >>是追加写入,>是覆盖写入
ip a

另外执行 ps -A | grep wpa_supplicant,也能看到
2770 ? 00:00:00 wpa_supplicant
如果有问题 用kill -9 进程号全部清除 再重新来一遍
接下来 cp -r /etc/resolv.conf /mnt/etc/resolv.conf
再进入chroot


#251

你做的多了,不然哪来的三个 wpa_supplicant :joy:

现在快去 chroot 然后更新 grub2 吧


#252

你太客气了,而且我还年轻,大兄弟😂


#253

我都是按照那个执行的呀,


#254

一下四张照片 分别是执行上述四个命令的结果
zypper mr -da


zypper ar -f Index of /tumbleweed/repo/oss oss

zypper ref

zypper up grub2 grub2-x86_64-efi


#255

然后再重装 grub


#256

你的kernel-default有没有装,还有mount,mount --bind?另外建议df -h 贴一下


#257

kernel-default已经装好了,mount这些一直就有,否则也进不去chroot。


#258

现在就可以执行这两步了么?
grub2-install --target=x86_64-efi /dev/sda7
grub2-mkconfig -o /boot/grub2/grub.cfg
系统知道该用哪一个grub2来安装么?
装好以后是否还需要检查一下efibootmgr -v和/etc/fstab 以及btrfs subvolume list /?


#259

执行。不用检查了,那些已经修好了。现在应该是 grub2 自己的问题


#260

安装成功了,是否重启?


#261

当然重启啊,有问题贴图