[已解决]dup 升级提示移除应用程序但无操作

#1

Tumbleweed 进行 dup 升级,总是提示要移除"Search and Indexing",但是又不会进行操作。

 sudo zypper dup
警告: 您正要使用全部已启用软件源进行发行版升级。继续前请确保这些源之间相互兼容。参考 'man zypper' 获知更多关于此命令的信息。
正在加载软件源数据...
正在读取已安装的软件包...
正在计算发行版升级...

以下 4 个项已被锁定并不会被任何操作改动:
 可用版本:
  gnome-packagekit ibus java-1_7_0-openjdk xboard

将移除以下 1 个应用程序:
  "Search and Indexing"

操作完成后,将不会占用或释放额外的空间。
无事可做。

试过在 init 3 环境下进行 dup,也是无果。如果卸载掉 tracker-gui 后再进行 dup,就没有提示要移除任何应用程序了,但是会安装回 tracker-gui 包,又回到之前状况。我搞不懂这是什么问题。

#2

你把那几项解除锁定再发一遍呢

从我的 iPhone 发送,使用 Tapatalk

#3

解除锁定,进行 dup 升级。还是会提示要移除应用程序。把锁定的那几个软件装了,再进行 dup,还是这样。

sudo zypper dup
警告: 您正要使用全部已启用软件源进行发行版升级。继续前请确保这些源之间相互兼容。参考 'man zypper' 获知更多关于此命令的信息。
正在加载软件源数据...
正在读取已安装的软件包...
正在计算发行版升级...

将移除以下 1 个应用程序:
  "Search and Indexing"

操作完成后,将不会占用或释放额外的空间。
无事可做。

此次操作的 zypper log paste.ubuntu.com/14476705/
启用的软件源
sudo zypper lr
# | 别名 | 名称 | 已启用 | GPG 检查 | 刷新
—±------------------------------------±----------------------------±-------±---------±----
1 | Bumblebee | Bumblebee | 是 | (r ) 是 | 是
2 | M17N | M17N | 是 | (r ) 是 | 是
3 | home:/bosim:/numix | home:/bosim:/numix | 是 | (r ) 是 | 是
4 | http-download.opensuse.org-c4a81aeb | home:/paolorotolo:/numix | 是 | (r ) 是 | 是
5 | http-download.opensuse.org-c64967f9 | Games:tools | 是 | (r ) 是 | 是
6 | http-download.opensuse.org-d7c3426a | Utilities | 是 | (r ) 是 | 是
7 | http-ftp.gwdg.de-1f749a53 | Packman Repository | 是 | (r ) 是 | 是
8 | openSUSE_Tumbleweed_1 | openSUSE_Tumbleweed | 是 | (r ) 是 | 是
9 | openSUSE_zh | home:/opensuse_zh | 是 | (r ) 是 | 是
10 | repo-debug | openSUSE-Tumbleweed-Debug | 否 | ---- | 是
11 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | 是 | (r ) 是 | 是
12 | repo-oss | openSUSE-Tumbleweed-Oss | 是 | (r ) 是 | 是
13 | repo-source | openSUSE-Tumbleweed-Source | 否 | ---- | 是
14 | repo-update | openSUSE-Tumbleweed-Update | 是 | (r ) 是 | 是

#4

看一下

sudo zypper se -t application “Search and Indexing”

输出了什么

#5
sudo zypper se -t application "Search and Indexing"
正在加载软件源数据...
正在读取已安装的软件包...

S | 名称                | 摘要                                 | 类型    
--+---------------------+--------------------------------------+---------
i | Search and Indexing | Configure file indexing with Tracker | 应用程序
#6
$ zypper search -t application "Search and Indexing"
Loading repository data...
Reading installed packages...
     
S | Name                | Summary                              | Type      
--+---------------------+--------------------------------------+------------
| Search and Indexing | Configure file indexing with Tracker | application




$ zypper in -t application "Search and Indexing"
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 2 applications are going to be installed:
  "Desktop Search" "Search and Indexing"

The following 17 NEW packages are going to be installed:
  libcue1 libenca0 libexempi3 libgsf-1-114 libgxps2 libiptcdata libiptcdata0 libmediaart-1_0-0 libosinfo libosinfo-1_0-0 libtracker-common-1_0 libtracker-control-1_0-0 libtracker-miner-1_0-0
  libtracker-sparql-1_0-0 tracker tracker-gui tracker-miner-files

The following 2 recommended packages were automatically selected:
  tracker tracker-miner-files

17 new packages to install.
Overall download size: 3.0 MiB. Already cached: 0 B  After the operation, additional 8.7 MiB will be used.

所以你想要搞定那个提示的话,tracker tracker-gui tracker-miner-files 这三个包同时都别装应该就可以了。注意移除的时候不要用 -u,你要是 GNOME 的话,好像 nautilus 是需要 tracker 的。

#7

我用的 GNOME 桌面,tracker 是要保留的。只有 tracker-gui 可以直接移除没被依赖,之前移除过这个包不提示问题了,但是这个包又是软件源推荐安装的。

sudo zypper in -t application "Search and Indexing"
Loading repository data...
Reading installed packages...
'application:Search and Indexing' is already installed.
Package 'Search and Indexing' is not available in your repositories. Cannot reinstall, upgrade, or downgrade.
Resolving package dependencies...

The following application is going to be REMOVED:
  "Search and Indexing"

No additional space will be used or freed after the operation.
Nothing to do.

上面的信息里,软件源里没了这个软件包,有点奇怪。

#8

sudo zypper rm -u -t application “Search and Indexing”

看看系统想移除什么?

#9
sudo zypper rm -u -t application "Search and Indexing"
root's password:
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following application is going to be REMOVED:
  "Search and Indexing"

No additional space will be used or freed after the operation.
Nothing to do.

另外 YaST2 里查看的

!](http://paste.opensuse.org/images/28431489.png)

#10

在虚拟机里新装了个 Tumbleweed Gnome,zypper dup 也是出现这个提示。

#11

把 tracker-gui 在 YaST 里设置成禁手吧。

#12

附上 openSUSE 官方论坛的相关帖子 forums.opensuse.org/showthread.php/512717-Zypper-the-following-application-is-going-to-be-REMOVED-quot-Search-and-Indexing-quot?highlight=search+indexing
看网友的解释是 tracker 的打包问题。
此问题也先标为已解决。