Firefox 访问html5 网页的问题


#1

请问各位,firefox 由于版权问题,无法正常访问 html5 的网页视频,,请问大家有什么办法解决的。谢谢。。是否安装如下就可以?

Gensupport:/home/teran # zypper in ffmpeg
Loading repository data…
Reading installed packages…
Resolving package dependencies…

Problem: ffmpeg-3.3.4-9.1.x86_64 requires libavcodec57 = 3.3.4-9.1, but this requirement cannot be provided
uninstallable providers: libavcodec57-3.3.4-9.1.x86_64[Packman42.3]
Solution 1: Following actions will be done:
install libavcodec57-3.3.4-9.1.x86_64 (with vendor change)
openSUSE --> packman.links2linux.de
install libswscale4-3.3.4-9.1.x86_64 (with vendor change)
openSUSE --> packman.links2linux.de
install libswresample2-3.3.4-9.1.x86_64 (with vendor change)
openSUSE --> packman.links2linux.de
install libavformat57-3.3.4-9.1.x86_64 (with vendor change)
openSUSE --> packman.links2linux.de
install libavutil55-3.3.4-9.1.x86_64 (with vendor change)
openSUSE --> packman.links2linux.de
Solution 2: do not install ffmpeg-3.3.4-9.1.x86_64
Solution 3: break ffmpeg-3.3.4-9.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] ©: c


#2

gstreamer-libav 吧好像

从我的 iPhone 发送,使用 Tapatalk


#3

关键是要安装 libav* 的各种包。不知道是不是需要 gstreamer 再套一下,Firefox 好像是可以直接用 libav 的。


#4

看上面的提示应该是你没有添加 packman 源吧!把 packman 源添加上,然后再使用 zypper inr 命令安装一下新的功能,这一步有可能就将 flash 啊什么的都安装了。然后你再试着安装一下 flash 和 ffmpeg,来检验一下这两个软件是否有安装。安装这两个软件的时候,网络视频解码器之类的包,应该都会被自动选择并安装。这样,你再试一下看 Firefox 是否能播放 html5 视频。如果不行再专门找相应的安装包。


#5

现在我使用 firefox 56 64bit… flash 控件完全不能使用了。。然后观看 youku 视频 html5 无法显示。。。各位有什么好的解决方案? 希望不要使用 flash,因为这个被淘汰的。。


#6

上面不是给出方法了吗?你原来 zypper 的时候,选 1 就可以了。

参考: lists.opensuse.org/opensuse/2016-02/msg00289.html


#7

可以用改 User-Agent 的插件,把 Firefox 伪装成手机浏览器。这样 Youku 就会显示移动版网页,移动版是只有 HTML5 播放器的。


#8

优酷已经默认使用 HTML5 了,不过可以选择回退到 Flash 上。


#9

感谢各位支持,终于搞定 firefox56 html5 的视频支持了。。还是老办法 zypper in ffmeg … 估计以后 flash 网页游戏是玩不了。。万分感谢。。。


#10

Flash 插件的问题可以关注下面这个主题讨论
lists.opensuse.org/opensuse-factory/2017-10/msg00597.html