开启热点需要输入root密码


#1

Tumbleweed,桌面环境KDE,已更新到最新。

情况是在开启热点的时候需要输入root密码,十分不便:

Screenshot_20180509_194027

根据提示显示应该是polkit配置的原因,不过我不太了解相关配置方法。根据一些资料检查了文件配置:

/usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy

<action id="org.freedesktop.NetworkManager.wifi.share.protected">
  <description>Connection sharing via a protected WiFi network</description>
  ...
  <defaults>
  <allow_inactive>no</allow_inactive>
  <allow_active>yes</allow_active>
  </defaults>
</action>

allow_active的设置为yes,按理说是不需要认证的啊。不知道有没有遇到相同问题的朋友,是如何解决的呢?


#2

NM 里面应该有个选项是允许所有用户连接到此网络,取消勾选试试。


#3

默认就是未勾选的状态,尝试勾选后连接依然需要输入root密码。
Screenshot_20180510_130510


#4
sudo echo org.freedesktop.NetworkManager.wifi.share.protected yes:yes:yes > /etc/polkit-default-privs.local

#5

sudo重定向权限不足,切换root执行后问题解决。现在终于不用输入密码了,感谢!


#6

女王,女王,每次你都这样直接给方案,
可这样的答案是怎么找到的呢,怎样自己动手?


#7

我在veracrypt中也遇到了类似的问题。

具体表现为:普通用户挂载经过veracrypt加密的移动硬盘,这货居然要root密码。而,没有加密的移动硬盘,就不需要。

希望开发者重视这些细节上的东西 :roll_eyes:


#8

我翻了一下openSUSE Security Guide关于policykit的内容

才发现oepnSUSE在/etc/polkit-default-privs.standard配置了一组默认权限,覆盖了org.freedesktop.NetworkManager.policy的设置。

其中org.freedesktop.network-manager-settings.system.wifi.share.protectedauth_admin,导致需要root权限。

通过在/etc/polkit-default-privs.local配置用户权限覆盖/etc/polkit-default-privs.standard的配置就解决了这个问题。

英文手册看得太痛苦所以之前没有注意到这个。


#9

又来一个问题,所以为什么standard会与NetworkManager不同,默认使用更严格的权限设置?是不是这个是 SLE 企业发行版的配置给带到社区版上来了。如果是桌面用途,应该不会想用这种更高的安全限制。Leap的polkit该不会也是SLE的一部分吧,一套共用的配置并不能切合每种使用场景的需求,也许polkit的配置应该分得更细。