opensuse_zh 源的 wps-office 在 15.0 下依赖有问题


#1

官方并没有为 15.0 打 libffi4 这个包,而 wps-office 依赖这个包。
这是 libffi4 的支持情况:


openSUSE-Gossip-20180403-20180625
#2

按理来说 15.0 应该转而依赖 libffi7,也就是 libffi?
另外 http://wps-community.org/downloads 提供了 10.1.0.5707~a21 版本,可以考虑更新一下。


#3

wps都不更新了,有点可惜!


#4

持乐观态度。WPS 好像是表示过 Linux 版没被放弃维护的。只是这个发布间隔确实… 像 5672 版和 5707 版就相隔了整整一年…


#5

也是因为依赖问题(tw),自己去官网下了rpm:sweat_smile:


#6

按照现在的状态,TW 倒是可以试着加 devel:gcc 来解决依赖问题…


#7

:joy: 感觉自己装还是方便点

话说我发现在没有装wps之前libre还是能默认打开docx,pptx,xlsx这些文件,装了之后貌似识别就有点问题了,比如识别为zip ,从其他帖子貌似也看到过这样的状况,源里面的wps有这个问题么?或者说有没有什么好办法解决 ?


#8

表示自从发现我用 LibreOffice 保存的 MS Office 2007+ 格式文件基本无法使用其它办公套件打开后,我就只用 MS Office 2003 的格式了…


#9

这样啊 :joy:


#10

回头我看看


#12

https://build.opensuse.org/request/show/613767

现在应该好了


#13

个人觉得用 Golang 写安装器不是好的选择。Golang 不是 openSUSE 默认安装库,也不是 wps 的依赖库,为了安装 WPS 却引入不相关的依赖,会造成系统组件的冗余。而且,SUSE Enterprise 不带 Golang 的库,也就是说,企业版用户无法直接使用这个安装器。用 bash 以及 python 显然比 Golang 更合适。


#14

编译好的 static binary 不存在依赖关系


#15

那这个问题如何破?企业版根本就不提供 Golang.

2018-06-04%2016-30-56%20%E7%9A%84%E5%B1%8F%E5%B9%95%E6%88%AA%E5%9B%BE


#16

企业版的事情自然由企业来解决啊…再说了 SLE 有 golang 的,不然你觉得 docker 怎么办 :joy:


#17

当然是选择一键 disable (


#18

2 个帖子被分离到了新主题:wps-office 6684 版本更新


#19