菜鸡搞半天还是弄不好samba,求助……


#1

搞了半天,samba还是没法用,windows10还是无法访问到opensuse上的共享文件夹。唉……求助一下大家,谢谢。


#2

你都做了哪些尝试?


#3

Linux上设置与Windows共享的目录

mkdir /home/XXX/Share
chmod 777 /home/XXX/share # 注意:XXX为用户名

1. 修改配置文件

sudo gedit /etc/samba/smb.conf

在smb.conf最后添加

[share]
    comment = File Server Share
    path = /home/XXX/Share
    browsealbe = yes
    guest ok = yes
    read only = no
    create mask = 0755

2. 创建samba账户

sudo smbpasswd -a XXX

如果没有这一步,当你登录时会提示 session setup failed: NT_STATUS_LOGON_FAILURE。

3. 运行samba服务,设置开机启动

sudo systemctl start smb.service
sudo systemctl start nmb.service
sudo systemctl enable smb.service
sudo systemctl enable nmb.service

4. 在Yast中开启samba,samba-client的防火墙端口


#4

我以前都是按照这个来配置的,都是没有问题的。


#5

我以前用Manjaro,Ubuntu都是这么配置的,Windows10都可以访问linux上的共享文件夹,这次配置openSUSE搞不定了……


#6

我没有用直接改smb.conf,我是在yast里面samba server处配置的。


#7

私信你了,谢谢


#8

防火墙?不想折腾就用yast配置


#9

谢谢,已经搞定了。是windows10上需要设置,害得我在linux上折腾半天。


#10

跟win10有关系?win10要怎么设定?我也是设置了半天都不成功


#11

注册表里关掉Win10的UAC吧
以前这样子搞可能就不能用计算机啥的


#12

win10连接的时候,会弹出错误提示,然后你百度一下这个错误提示,就能找到解决方法了.


#13

Win7要设置才能访问,Win10应该也是这情况吧


#14

学习中。。。我就看看。。。


#15

在Win10上设置如下试试,我Win7就那样设置才可以访问。

单击”开始“-“运行”,输入secpol.msc,打开“本地安全策略”,在本地安全策略窗口中依次打开“本地策略”–>“安全选项”,然后再右侧的列表中找到“网络安全:LAN 管理器身份验证级别”,把这个选项的值改为“发送 LM 和 NTLM – 如果已协商,则使用 NTLMv2 会话安全”,最后确定。