tumbleweed安装更新只能命令行了


#1

那个安装更新的按钮不显示了,现在只能zypper dup命令行更新了,求助


#2

是 openSUSE 官方有意这么做的。KDE 的软件更新比较 bug,对 Tumbleweed 这种经常有包的拆分/淘汰/改名的滚动发行版,可能会导致升级错误。因此官方禁用了这个自动更新按钮。zypper dup 是最安全的。

举个例子,假如软件包 a b c 被淘汰了,而他们又依赖老版本的 d e f 库,KDE 的软件更新会保留这些个包 a b c,并且不会更新 d e f。久而久之系统的依赖关系就会出问题,甚至可能无法开机。