42.3怎么安装最新版的emacs?


#1

我在WSL中使用openSUSE,版本为42.3。想要安装最新版的emacs有什么方法?
我尝试过下载emacs 26.1的源码包直接编译,但老是提醒缺少libjpeg libpng等库,就算安装了也仍然无法正常编译。


openSUSE-Gossip-20180626-20180924
#2

使用这里的链接一键安装:
https://software.opensuse.org/ymp/editors/openSUSE_Leap_42.3/emacs.ymp?base=openSUSE%3ALeap%3A42.3&query=emacs


#3

谢谢,请问下这个一键安装在命令行下可以使用吗?因为我用WSL所以是没有图形界面的。


#4

可以的,用yast2打开就行了。
或者你可以运行如下命令:
sudo zypper ar http://download.opensuse.org/repositories/editors/openSUSE_Leap_42.3/ editor
sudo zypper ref
sudo zypper up emacs

然后选择更换vendor。


#5

成功解决,谢谢了!