Firefox 打开视频网站播放提示版本过低


#1

Screenshot_20181112_231121


openSUSE-Gossip-20180925-20181231
#2

网站检测相应的控件和你的User Agent(UA)并以此推测你的浏览器版本。要么是火狐的flash控件太低,要么是你运行一下系统更新看看火狐有没有更新。默认的flash支持火狐似乎并不好。


#3

Flash 在 Firefox 也挺正常的。这个可能是装了强制优酷使用 HTML5 的扩展或脚本,禁用或加入白名单就可以播放了。优酷自己有 HTML5 播放器但有些视频还是用的 Flash 播放。


#4

很多视频默认还是flash,这就很有可能了。


#5

我试了这个视频,在我的电脑上正常。默认用的HTML5播放器。TW+Fx 62。


#6

手动添加 pacman社区源,然后运行zypper update升级flashplayer至新版本即可。


#7

我的 FF 默认的 Shockware Flash 插件是这个: /usr/lib64/browser-plugins/libfreshwrapper-flashplayer.so,来自 flash-player-ppapi。

你可以试试这个。也可以使用 chromium-pepper-flash + freshplayerplugin 这个组合使用 chromium 的 flash plugin 来放 FF 里的 flash 视频。


#8

可以选择添加源:sudo zypper addrepo -f http://packman.inode.at/suse/openSUSE_Leap_15.0/ packman
安装Flash: sudo zypper install freshplayerplugin
安装多媒体插件:sudo zypper install xine-browser-plugin
然后打开Firefox浏览器:firefox &