“软件包更新程序” 更新软件的时候报错


#1

patch:openSUSE-2018-1017-1.noarch 与 zypper-log.noarch < 1.14.10-lp150.2.3.1 冲突,后者由 zypper-log-1.14.5-lp150.1.1.noarch 提供
patch:openSUSE-2018-1024-1.noarch 与 zypper-aptitude.noarch < 1.14.11-lp150.2.6.1 冲突,后者由 zypper-aptitude-1.14.5-lp150.1.1.noarch 提供
patch:openSUSE-2018-1231-1.noarch 与 zypper.x86_64 < 1.14.12-lp150.2.9.2 冲突,后者由 zypper-1.14.5-lp150.1.1.x86_64 提供
patch:openSUSE-2018-1403-1.noarch 与 typelib-1_0-PackageKitGlib-1_0.x86_64 < 1.1.10-lp150.3.3.1 冲突,后者由 typelib-1_0-PackageKitGlib-1_0-1.1.10-lp150.2.1.x86_64 提供


#2

你可以检查下你的源 zypper lr 系统更新相关的源保留一套就行了,一般一套是四个repo-oss,repo-non-oss,repo-update,repo-update-non-oss。安装软件如果依赖冲突会提供解决方案,通常选择解决方案1就行,如果碰到其它问题,可以先搜索下,再者可以问下别人,一般安装系统提供的软件问题都不大。


#3

谢谢,就按照您说的处理的,问题已经解决了


#4

本主题在最后一个回复创建后60分钟后自动锁定。不再允许添加新回复。