萌新发个帖,Tumbleweed搜狗输入法报错解决


#1

右上角一直提示搜狗输入法错误,请删除.config/sogouPY 后重启,怎么做都不行

后来启动sogou-qimpanel,提示找不到libQtWebKit.so.4 ,后来找个包,装上的是32bit的不行,换了
64bit还是找不到 然后whereis libQtWebKit.so.4 在/usr/lib/qt4/lib64/libQtWebKit.so.4 里面,我就软链接到了/usr/lib里,貌似还可以将/usr/lib/qt4/lib64 加入到/etc/ld.so.conf 但是/usr/lib/qt4/lib64/啥也没有,我试了软链接也可以

然而继续报错,再启动sogou-qimpanel ,这次是找不到libidn.so.11 ,wheris找到的是libidn.so.12,在解决前面的问题时候看到个说版本可以向下兼容,就再软链接,ln -s /usr/lib64/libidn.so.12 /usr/lib64/libidn.so.11 再sogou-qimpanel ,启动成功!:joy_cat:


#2

不用就完事了