15.0 安全补丁和推荐包需要安装吗?


#1

42.3 dup 到 15.0 后 桌面面板里的 Software Updates 小工具提示有更新,看了下是 安全补丁和推荐的包,点击更新后安装失败,提示某个包不存在。因为有事没管。
这些需要安装吗?

现在用 zypper 查看是这样

$ zp pchk
正在加载软件源数据...
正在读取已安装的软件包...

找到了 44 个可应用的补丁:
分类        | 补丁
------------+-----
security    | 22  
recommended | 22  

需要 44 个补丁 (22 个安全补丁)


$ zp lp
正在加载软件源数据...
正在读取已安装的软件包...

软件源              | 名称               | 分类        | 严重性    | 交互的 | 状态 | 摘要                                                    
--------------------+--------------------+-------------+-----------+--------+------+---------------------------------------------------------
QingHua_15.0-Update | openSUSE-2018-1007 | recommended | moderate  | ---    | 需要 | Recommended update for tigervnc                         
QingHua_15.0-Update | openSUSE-2018-1067 | recommended | low       | ---    | 需要 | Recommended update for myspell-dictionaries             
QingHua_15.0-Update | openSUSE-2018-1107 | security    | moderate  | ---    | 需要 | Security update for libX11                              
QingHua_15.0-Update | openSUSE-2018-1171 | recommended | moderate  | ---    | 需要 | Recommended update for alsa                             
QingHua_15.0-Update | openSUSE-2018-1173 | recommended | moderate  | ---    | 需要 | Recommended update for tigervnc                         
QingHua_15.0-Update | openSUSE-2018-1196 | security    | important | ---    | 需要 | Security update for texlive                             
QingHua_15.0-Update | openSUSE-2018-1227 | security    | moderate  | ---    | 需要 | Security update for clamav                              
QingHua_15.0-Update | openSUSE-2018-1228 | security    | moderate  | ---    | 需要 | Security update for fuse                                
QingHua_15.0-Update | openSUSE-2018-1266 | recommended | moderate  | ---    | 需要 | Recommended update for plymouth                         
QingHua_15.0-Update | openSUSE-2018-1327 | security    | moderate  | ---    | 需要 | Security update for lcms2                               
QingHua_15.0-Update | openSUSE-2018-1349 | recommended | moderate  | ---    | 需要 | Recommended update for alsa                             
QingHua_15.0-Update | openSUSE-2018-1371 | recommended | moderate  | ---    | 需要 | Recommended update for cpupower                         
QingHua_15.0-Update | openSUSE-2018-1396 | recommended | moderate  | ---    | 需要 | Recommended update for ethtool                          
QingHua_15.0-Update | openSUSE-2018-1417 | security    | moderate  | ---    | 需要 | Security update for LibreOffice and dependency libraries
QingHua_15.0-Update | openSUSE-2018-1457 | recommended | moderate  | ---    | 需要 | Recommended update for apparmor                         
QingHua_15.0-Update | openSUSE-2018-1485 | security    | moderate  | ---    | 需要 | Security update for glib2                               
QingHua_15.0-Update | openSUSE-2018-1501 | recommended | low       | ---    | 需要 | Recommended update for Mesa                             
QingHua_15.0-Update | openSUSE-2018-1540 | security    | moderate  | ---    | 需要 | Security update for mozilla-nss                         
QingHua_15.0-Update | openSUSE-2018-1543 | recommended | moderate  | ---    | 需要 | Recommended update for plymouth                         
QingHua_15.0-Update | openSUSE-2018-1561 | recommended | moderate  | ---    | 需要 | Recommended update for libcdio                          
QingHua_15.0-Update | openSUSE-2018-1568 | recommended | low       | ---    | 需要 | Optional update for gcc8                                
QingHua_15.0-Update | openSUSE-2018-1577 | recommended | moderate  | ---    | 需要 | Recommended update for libgcrypt                        
QingHua_15.0-Update | openSUSE-2018-1596 | security    | moderate  | ---    | 需要 | Security update for bluez                               
QingHua_15.0-Update | openSUSE-2018-1597 | security    | moderate  | ---    | 需要 | Security update for libnettle                           
QingHua_15.0-Update | openSUSE-2018-1618 | security    | moderate  | ---    | 需要 | Security update for mozilla-nspr and mozilla-nss        
QingHua_15.0-Update | openSUSE-2018-498  | recommended | moderate  | ---    | 需要 | Recommended update for bind                             
QingHua_15.0-Update | openSUSE-2018-575  | security    | important | ---    | 需要 | Security update for MozillaFirefox, mozilla-nss         
QingHua_15.0-Update | openSUSE-2018-744  | recommended | moderate  | ---    | 需要 | Recommended update for bluez                            
QingHua_15.0-Update | openSUSE-2018-745  | recommended | moderate  | ---    | 需要 | Recommended update for bind                             
QingHua_15.0-Update | openSUSE-2018-769  | security    | moderate  | ---    | 需要 | Security update for libgcrypt                           
QingHua_15.0-Update | openSUSE-2018-771  | security    | moderate  | ---    | 需要 | Security update for e2fsprogs                           
QingHua_15.0-Update | openSUSE-2018-838  | security    | moderate  | ---    | 需要 | Security update for clamav                              
QingHua_15.0-Update | openSUSE-2018-857  | security    | low       | ---    | 需要 | Security update for libcdio                             
QingHua_15.0-Update | openSUSE-2018-930  | recommended | moderate  | ---    | 需要 | Recommended update for texlive                          
QingHua_15.0-Update | openSUSE-2019-178  | recommended | moderate  | ---    | 需要 | Recommended update for glib2                            
QingHua_15.0-Update | openSUSE-2019-183  | security    | important | ---    | 需要 | Security update for mozilla-nss                         
QingHua_15.0-Update | openSUSE-2019-195  | security    | moderate  | ---    | 需要 | Security update for nginx                               
QingHua_15.0-Update | openSUSE-2019-196  | security    | critical  | ---    | 需要 | Security update for LibVNCServer                        
QingHua_15.0-Update | openSUSE-2019-197  | security    | moderate  | ---    | 需要 | Security update for avahi                               
QingHua_15.0-Update | openSUSE-2019-203  | security    | important | reboot | 需要 | Security update for the Linux Kernel                    
QingHua_15.0-Update | openSUSE-2019-204  | security    | important | ---    | 需要 | Security update for chromium                            
QingHua_15.0-Update | openSUSE-2019-29   | recommended | low       | ---    | 需要 | Recommended update for acl                              
QingHua_15.0-Update | openSUSE-2019-33   | recommended | moderate  | ---    | 需要 | Recommended update for apparmor                         
QingHua_15.0-Update | openSUSE-2019-56   | recommended | moderate  | ---    | 需要 | Recommended update for mozilla-nss                      

找到了 44 个可应用的补丁:
需要 44 个补丁 (22 个安全补丁)

#2

手动跑一下 sudo zypper up 即可。


#3

跑 sudo zypper up 没有这些,也就是说不用管这些了?


#4

zp 这个命令缩写挺有意思,看看能不能官方一下。