已解决:双系统,已装好win10,求助LEAP15的分区

#1

打算重装opensuse leap 15,这次坚决不用btrfs。
两块4T硬盘,sda上面看已经装好了win10,sdb空出来430G,打算装leap 15
1 对安装程序默认的分区方案不满意,打算用ext4格式,而且/home和根分区不要分开,同时不需要/swap分区,大不了安装好系统以后,再生成一个binary文件作为缓存文件。我记得过去, 2014年左右就曾这么做过。而且可以生成若干个这样的文件,
所以我选择Expert --> Current Proposal
Uploading: 01B26A64-4DE0-4A65-BA56-E5EFD4AF3893.jpeg…
2 发现bios boot partition总是只给我8MB,这个size够不够大?要不要扩充到128MB?
%E5%9B%BE%E7%89%87
3 折腾了半天,这样分区可以么?
这里的问题是/dev/sdb2 的挂载点是不是需要自己手动填进去?另外默认是“Do not format”。是不是要格式化?

#2

没想明白为啥不将//home分开,今后重装,直接挂载/home还能保留数据。

挂载点记得都是可选的。。

(图是被谁吃了么 :joy:

#3

图上传不上去,一直说uploading
既然这样就分开。
那样的话,/只有40G,够么?80G比较合适吧?
efi只有8M,够么?
补图
%E5%9B%BE%E7%89%87 %E5%9B%BE%E7%89%87

#4

efi 默认只给8M , 是不是有问题?》

#5

觉得有问题,给个256再说

40G 感觉有点小,毕竟btrfs,快照不清挺占地方的

swap 给这么多?,一般给和内存差不多吧。日常使用用得到的时候并不多。

Has Likes
#6

不是说坚决不用btrfs么,你这/dev/sdb3还是btrfs啊。
我的partition plan:
/boot/efi 300MB FAT
/ 200 GB XFS
/home 0.71TB XFS

Has Likes
#7

我这个截图是安装程序的默认,我还什么都没做呢,不敢乱动

#8

不是不是,我的截图是安装程序的默认设置,我还什么都没做呢,因为不敢乱动。
我打算只分三个区:

  1. /boot/efi,要不索性512M,而且是不是得格式化?
  2. / 计划用ext4 ,分配160G
  3. /home,计划也用ext4, 剩下的都给他
#9

我发现了,在这个界面里
%E5%9B%BE%E7%89%87
选择第二个选项
“Start with existing partitions”
%E5%9B%BE%E7%89%87

可是点击accept以后出来警告说“系统可能无法启动,需要bios boot分区”

#10

这里是不是必须选择Bios boot partition而不是选择efi system partition?%E5%9B%BE%E7%89%87

#11

只要选择EFI Sytem Partition,就是所谓的ESP吧?
就有这个警告:
%E5%9B%BE%E7%89%87

问题是不是出在主板设置上面?我选择的是uefi+传统bios启动,其他的选项有“仅传统bios启动”、“仅uefi启动”

#12

这都9102年了,没装有什么不支持UEFI的系统就去设置一下「仅UEFI启动」吧。

然后应该就不会提示给「BIOS分区」了,然后格不格式化取决于有没有东西,没东西格格没啥毛病


我的分区:
image

home 在另一个盘,
单独分了 /usr/local 是因为准备在这128G巨大SSD上装点其他的开发环境什么的,便于以后重装,不会丢这儿的数据,
swap 给了10G,虽然我只有 8G 内存(最近看来还是有点用的,AS+Chrome 这个组合真暴力。。。

Has Likes
#13

十分先进合理好顶赞

我的电脑是2013年攒的,一直没换过。

#14

不行,用这个办法装好以后重启,机器完全无视opensuse,只能启动win10

#15

BIOS启动选项里有大蜥蜴的么?

手动选择也不行?

#16

目前只能在开机以后F12选择启动哪个硬盘,
现在进入了plasma桌面,上不了网。

最初的问题基本解决了,就是进入exisiting partition
手动依次add 三个分区 分别挂载到/boot/efi,/和/home

现在的问题是重装了leap15,还是不能上网。

#17

现在更麻烦,在yast2->Network settings里启用了ipv6,重启再进入plasma,打开Firefox,就直接死机了,鼠标能动,键盘灯不灭,桌面没有任何响应,刚装的系统。

#18

只好强行重启,这次更操蛋,刚进入桌面,桌面壁纸没了不说,桌面上的两个图标没有了,右单击不出来菜单。
什么玩意,刚装的系统

#19

个人感觉是显卡问题,你是什么显卡?

#20

比较老,gt640,2012年买的。
刚才死机以后强行重启,这次进入了桌面,可是上不了网。