opi: 在命令行搜索安装 OBS 软件包

#1

OBS Package Installer

系统需求

  • openSUSE Tumbleweed, openSUSE Leap 42.1+, SLE 12+
  • perl
  • perl-libwww-perl
  • perl-XML-LibXML
  • perl-URI
  • perl-Config-Tiny

安装

sudo zypper addrepo https://download.opensuse.org/repositories/home:guoyunhe/openSUSE_Tumbleweed/home:guoyunhe.repo
sudo zypper refresh
sudo zypper install opi

使用

命令:

opi filezilla

输出:

Has Likes
#2

这个脚本厉害了

#3

很方便 啊

#4

提一个小建议不知可否,就是如果每一行间的相同类型的项目(比如包名,大小,版本号等)可以都上下对齐的话会更方便查看。

#5

刚修改了一下,在 0.3.0 里,结果稍微对齐了

#6

openSUSE Leap 15.0 的结果都是 No package found. :thinking:

#7

#8

获取系统版本号的时候忘记去掉双引号了。我刚打包了 0.3.1,你更新一下看看这个问题还有没有。我现在手头上没有 Leap,测试有限。

#9

已经可以了

Has Likes
#10

6啊,可惜用的是leap

#11

Leap 应该也支持的,如果有问题可以 @ 我。