保留的 Leap 42.1 突然无法进入图形界面

#1

保留了一个42.1,之前一直正常,前些日子突然进不了图形界面了。
当时插了一个小u盘,出现一些英文提示,没在意,也没看具体是什么。
结果就进不了图形界面了。我以为系统出错,还原了之前用tar备份的系统,还是一样。

手动 startx,普通用户日志如下。sudo 运行可进图形见面,在tty2.

日志:

概要

[ 513.784]
X.Org X Server 1.17.2
Release Date: 2015-06-16
[ 513.784] X Protocol Version 11, Revision 0
[ 513.784] Build Operating System: openSUSE SUSE LINUX
[ 513.784] Current Operating System: Linux linux-nlvk 4.1.39-56-default #1 SMP PREEMPT Mon May 1 04:41:25 UTC 2017 (5f49ec2) x86_64
[ 513.784] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.1.39-56-default splash=silent quiet
[ 513.785] Build Date: 20 April 2017 02:49:53PM
[ 513.785]
[ 513.785] Current version of pixman: 0.32.6
[ 513.785] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 513.785] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 513.785] (==) Log file: “/home/user/.local/share/xorg/Xorg.0.log”, Time: Tue Apr 30 16:46:51 2019
[ 513.785] (==) Using config file: “/etc/X11/xorg.conf”
[ 513.785] (==) Using config directory: “/etc/X11/xorg.conf.d”
[ 513.785] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[ 513.785] (==) ServerLayout “Layout0”
[ 513.785] (
) |–>Screen “Screen0” (0)
[ 513.785] () | |–>Monitor “Monitor0”
[ 513.785] (
) | |–>Device “Device0”
[ 513.785] () |–>Input Device “Keyboard0”
[ 513.785] (
) |–>Input Device “Mouse0”
[ 513.785] (==) Automatically adding devices
[ 513.785] (==) Automatically enabling devices
[ 513.785] (==) Automatically adding GPU devices
[ 513.786] (WW) The directory “/usr/share/fonts/misc/sgi” does not exist.
[ 513.786] Entry deleted from font path.
[ 513.786] (==) FontPath set to:
/usr/share/fonts/misc:unscaled,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi:unscaled,
/usr/share/fonts/75dpi:unscaled,
/usr/share/fonts/ghostscript/,
/usr/share/fonts/cyrillic:unscaled,
/usr/share/fonts/truetype/,
built-ins
[ 513.786] (==) ModulePath set to “/usr/lib64/xorg/modules”
[ 513.786] (WW) Hotplugging is on, devices using drivers ‘kbd’, ‘mouse’ or ‘vmmouse’ will be disabled.
[ 513.786] (WW) Disabling Keyboard0
[ 513.786] (WW) Disabling Mouse0
[ 513.786] (II) Loader magic: 0x80dce0
[ 513.786] (II) Module ABI versions:
[ 513.786] X.Org ANSI C Emulation: 0.4
[ 513.786] X.Org Video Driver: 19.0
[ 513.786] X.Org XInput driver : 21.0
[ 513.786] X.Org Server Extension : 9.0
[ 513.789] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_33
[ 513.789] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 513.789] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[ 513.790] (–) PCI:*(0:0:13:0) 10de:03d6:1043:83a4 rev 162, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xdd000000/16777216, BIOS @ 0x???/131072
[ 513.790] (II) LoadModule: “glx”
[ 513.791] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 513.808] (II) Module glx: vendor=“NVIDIA Corporation”
[ 513.808] compiled for 4.0.2, module version = 1.0.0
[ 513.808] Module class: X.Org Server Extension
[ 513.808] (II) NVIDIA GLX Module 304.135 Tue Jan 17 15:46:50 PST 2017
[ 513.808] (II) LoadModule: “nvidia”
[ 513.808] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 513.809] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 513.809] compiled for 4.0.2, module version = 1.0.0
[ 513.809] Module class: X.Org Video Driver
[ 513.809] (II) NVIDIA dlloader X Driver 304.135 Tue Jan 17 15:28:00 PST 2017
[ 513.809] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 513.809] (EE)
Fatal server error:
[ 513.809] (EE) parse_vt_settings: Cannot open /dev/tty0 (No such file or directory)
[ 513.809] (EE)
[ 513.809] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 513.810] (EE) Please also check the log file at “/home/user/.local/share/xorg/Xorg.0.log” for additional information.
[ 513.810] (EE)

#2

l /dev/tty*看一下,还有screen /dev/tty0
lz竟然编辑帖子,不厚道啊

#3

root权限可以进图形界面的话
重新添加一个用户能登录进去的

#4

啊,说到添加用户,可以直接useradd -m xxx

#5

sudo 可进,恢复没用,那应该是 home 配置文件的问题

.config
.local

里面的东西一一排除一下

#6

这就是Xorg的锅 我上次是在root权限下面配置了个东西 然后把规则写到/home/.bashrc里面了
之后系统升级还是哪里动了一下 无法登入了 后来把那行代码

# export XAUTHORITY=~/.Xauthority

注释掉正常了

#7

对,还有 home 目录下的配置文件 :joy:

#8

先感谢各位热心回复。

之前一直能正常进图形界面,突然就进不了了。现在是x启动不了了,没有图形登陆界面,添加用户也没用。

启动卡在 Reached target Graphical Interface

我在18年9月,系统正常时用tar做了一个备份,包括根分区和主目录。完全恢复这个备份也进不了。

就是那次插u盘启动时出现英文提示后就不正常了,跟主板有关?插u盘能引起主板硬件/软件错误? 可15.0正常啊。

#9

参考一下
https://unix.stackexchange.com/questions/331233/arch-linux-hang-on-reached-target-graphical-interface

#10

ok,试试。谢谢!

#11

421 搞不好。我恢复了备份的423,正常。感谢各位!