VirutalBox 6.0.4 启动 Windows 蓝屏

#1

系统是Tumbleweed 20190428, VirtualBox 是 6.0.4
大约一周前,发现启动windows会出现蓝屏,截图如下

google了下,发现几个Arch下面的vbox也有同样的问题(大概是4月20号左右),但没找到怎么解决的,Arch那几个说的回退到6.0.2版本就好了,但Tumbleweed没法回退, 所以来问问。

顺便,还有个问题和VirtualBox相关。一年前由于内核的问题,自己编译了内核和VirtualBox,后来内核的问题修复了, 换了源的VirtualBox,但是每次安装VirtualBox的时候都会提示是否要覆盖已有的安装,from install of xxx (tum-oss) conflicts with file from package yyy (@system)。 这个怎么解?

#2

用KVM虚拟机呗

#3

已知 bug

https://bugzilla.opensuse.org/show_bug.cgi?id=1132941

用上述链接里面的Larry Finger编译的virtualbox可解


这里把步骤搬过来

wget http://lwfinger.com/download/virtualbox-6.0.6-0.x86_64.rpm
sudo zypper in --force virtualbox-6.0.6-0.x86_64.rpm

The new new package is not signed, thus ignore the warning that pops up.


可以关注一下这个 bug 上游测试完和进 factory 了就能直接滚了 :joy:

#4

如果认为重新安装比较繁琐的话不妨去v box官网下载旧版本的.run安装文件来使用

#5

感谢,还有总是提示这个 怎么解?每次都需要输入yes。。

#6

这个就不太清楚了 :joy:

这个版本是你以前自己装那个么?

#7

去年从virtualbox官网装的rpm包。

#8

去 YaST 里面搜 VirtualBox,会有一个红色的 5.x 版本,卸载掉再装就没有这个提示了

#9

删除出现错误,选择ignore后再次搜索还在。

#10

你 show details 看一下是什么情况呗。

不行就硬上,手动操作试试?

#11

它是想要运行 /usr/lib/virtualbox/prerm-common.sh 这个脚本,然而,这个脚本不存在。
要是知道在哪儿记录了这些信息就好办了。

#12

顺便搜了一下貌似找到了 :joy:

https://www.virtualbox.org/svn/vbox/trunk/src/VBox/Installer/linux/prerm-common.sh


大概看了一下貌似也没干什么 :joy:

建议可以先卸掉 virtualbox, 放上这个脚本,再去卸载试试,好使了在装上 virtualbox

#13

不用了。。我到官网重新下了个5.2.8的装上再卸载就好了。。

#14

机智 :smirk:

于关闭 #15

本主题在最后一个回复创建后60分钟后自动锁定。不再允许添加新回复。