Thinkpad P52 安装 Leap 42.3 后提示缺少 waln0 的内核设备,无线网卡是 Intel Wireless-AC 9560

#21

我明早去办公室后把型号和配置截图。感谢耐心解答:grin:

#22

不用了苏姐,那个a370就是9560,看到有人在debian的邮件列表里问了……

#23

请问对应的9560网卡驱动在哪里下载呢?

#24

已经确认是由于缺少内核设备(eth0,wlan0),无法进行网卡配置的原因,这大多是缺少固件(对于WLAN)引起的。应该下个对应的网卡驱动就好了。谢~

#25

我在intel官网看到了 Wireless-AC 9560驱动程序,但是只有win10版本。像linux系统的版本应该在哪里下载呢?

#26

已找到linux版本下载网站,贴一下https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networking.html

#27

你试试 sudo modprobe iwlwifi,不行就得编译安装你说的那个官方驱动了

#28

一个悲伤的故事…无论哪种方法,还是连不上wifi。YaST2-网络服务配置一栏全部处于禁用状态,装完驱动还是显示没有内核设备(eth0,wlan0),无法配置网卡。

#29

贴一下 uname -r 和 lsmod 的结果

#30

uname -r结果:4.4.76-1-default
lsmod结果如下:


#31

你这个 kernel 4.4 不行,9560 至少得 4.14 版本以上。Leap 15.1 都不行,因为它延续了 15.0 的 4.12.x 系列内核。你得上 Tumbleweed

#32

安装Tumbleweed 15.0可以解决这个问题吗?

#33

Tumbleweed 就是 Tumbleweed,没有 15.0,15.0 是 Leap。至少它的内核允许你编译安装官方驱动了呀。

#34

OK,我试试重装系统。

#35

[del]intel官网随便搜[/del]
原来已经找到了,恭喜

#36

蛤,是这样吗……4.14的神奇魔法

#37

Tumbleweed装好了。但是…一直卡在login这里,有什么解决办法吗?还是安装出了问题?

#38

#39

你……是用dvd断网装的吗?咋这么多毛病
登进去看一下journalctl -r

#40

我觉得这不是我的问题,是软硬件不匹配的问题。以前装过openSUSE13,很好装。总结这次U盘安装:(1)Leap 15.0卡在安装界面;(2)Leap 42.3无法联网;(3) Tumbleweed安装好后,开机后tty1 login,以root用户登录后,也是卡死。供网友参考。