5.1 内核翻车,近期请勿更新 Tumbleweed!

#1

https://www.redhat.com/archives/dm-devel/2019-May/msg00082.html

触发条件:

  1. SSD 存储
  2. 磁盘分区加密
  3. 开启 fstrim (默认开启)

后果:

数据丢失。

目前尚未有完整的报告,即使不符合以上条件的用户,也建议赶紧下车。

未升级的用户请勿升级 5.1 内核。已经升级的用户请以保留的旧的 5.0 内核启动,或者从 OBS 下载旧内核使用。

5.1都主线十天了……TW还不上?
#2

根据提醒,建议有如下操作:

uname -r 查看内核版本,若内核版本高于5.0.13 则执行:
sudo zypper al kernel*
进入YaST -> Boot Loader -> Bootloader Options中,选择Default Boot Section为
openSUSE Tumbleweed, with Linux 5.0.13-default

若未升级至5.1.2内核,请执行sudo zypper al kernel* 防止Kernel升级

#3

我看了好几次都还是 leap15.0,还以为时间未到,原来是时机未到。

#4

15.1 几分钟前发布了,用的旧内核,不受影响,稳。

#5

For now, all people having this issues used LVM, dm-crypt and some Samsung SSD.
https://forum.manjaro.org/t/kernel-5-1-fstrim-bug-with-dm-crypt-luks-and-device-mapper-lvm/88360/12

#6

15.1竟然用的是4.12.14-lp151.27-default

#7

看错:sweat_smile:,还以为是15.1翻车呢。

#8

所以滚动版不适合在生产力级环境部署。

#9

你可以看成由 SUSE 自己维护的版本分支,所有的安全补丁都会做 backport

#10

幸亏最近这几天一直忙,以前基本上每个周末dup一次,两年也没有出现过什么问题

于全站置顶 #11
#12

置顶一下防止有人看不到…有生之年系列啊

#13

笔记本上已更新,目前还没发现异常。

#14

这个翻车现场,使用btrfs的还能够抢救一下吗?:rofl:

#15

可能救不回来了。

#16

还好没有翻车,我用的就是dm-crypt加ssd,赶紧把5.1.5之前的kernel全卸掉了,该bug已在5.1.5修复。

#17

风滚草更新5.15了吗
vps用

#18

还没有,再等等吧

#19

所以说btrfs很重要
这种内核级的严重bug滚动发行版都能有
其他的bug你说会不会有
滚动发行版用ext4真的搞不好就会尸骨无存

#20

这个bug在lvm那层,一但触发什么文件系统都没用。