新版本的网易云音乐要glibc2.27

(Tommy Vercetti) #21

往上翻一下,我给了文件列表,找到这些文件并删掉,并安装我列出的依赖列表里的包

(fenglelyng) #22

哦,好吧谢了

(fenglelyng) #23

按照你的方法试过了还是不行,见图

(fenglelyng) #24

对了我不是安装的,我是直接解压缩使用的

(Tommy Vercetti) #25

我是安装的,我觉得可能他的安装脚本有一些特别的东西,你直接解压出来是不行的

你试着安个dpkg,接着用dpkg直接安装网易云音乐,再去删文件

(fenglelyng) #26

其实就是那个谷歌的什么浏览器框架找不到了

(fenglelyng) #27

https://github.com/ZetaoYang/netease-cloud-music-appimage/releases,你下载试试吧appimage格式的,省的麻烦了,另外你有空可以解压下看看内部是怎么实现的

(Tommy Vercetti) #28
(fenglelyng) #29

另外libc是2.17的

(fenglelyng) #30

我运行appimage格式的也不行,提示libm版本低。真是够了

(fenglelyng) #31

其实1.1还是能用的,就是以后可能就不支持了。

#32

我的提示我glibc_private未定义,emmm

(Incognito) #33

netease-cloud-music

(Tommy Vercetti) #34

obs上的版本太老了

(hillwood) #35

我没打算升级。

(hillwood) #36

Leap 上修改一下确实可以跑,但是不能下载还是不能下载,没有任何改进,所以我没有升级的欲望。

(Incognito) #37

不是不能下载,因为你下载的歌受版权保护,不信你下载花粥或徐秉龙等不是特别出名的歌手的歌试试

(Incognito) #38

那些受版权保护在Windows客户端下载出来的是ncm格式,不会是mp3,flac之类

(Incognito) #39

那版本更新的意义是什么?

(hillwood) #40

我是付费用户,是有权限下载受版权保护的音乐的。