codeblocks应该选择哪一个社区软件仓库来进行安装?

#1

想在openSUSE tumbleweed上安装codeblocks,但是openSUSE官方仓库OSS和non-OSS源都没有(以前用的是Debian和Ubuntu,都可以直接apt就能装了),

所以就去software.opensuse.org去找去搜索,是找出来了,但是那么多社区软件仓库,到底怎么确定哪一个才是比较可靠,下载的软件没那么多bug呢?怎么去确定呢?

各位大神你们有经验一些,能否指点迷津呢?不胜感激。

(xzhao) #2

欢迎使用openSUSE 中文软件源里面的:
https://build.opensuse.org/package/show/home:opensuse_zh/codeblocks
运行界面:

#3

这个看起来不错。我今天找个时间试试看。

#4

谢谢你的热心解答。

(hillwood) #5

这种合规的软件应该推到 oss 里面去。

(xzhao) #6

oss里面版本太低了,没法在15.2或者tumbleweed上面运行。而且devel:tools :ide这个开发库里面根本没有openSUSE 15.2和Tumbleweed的target。
不过我会尝试提交sr的。@hillwood

(hillwood) #7

提交 bug 后可以通过 update 更新。

#8

openSUSE是不错的一个发行版,但是可能是因为版权意识还是其他什么原因?软件包真的很少。。。好多都得去software.opensuse.org去找。。

(xzhao) #9

缺什么的话我来进行打包吧,当然国产软件或者不开源的软件除外。 @mkm19930608

(Tommy Vercetti) #10

你可以尝试直接白嫖红帽家centos或者fedora的rpm包,很多软件都不需要任何更改都能直接用
有的时候会有依赖问题,直接忽略掉就行,前提是你得吧依赖提前安好

还有code blocks真的能用么。。。

(Tommy Vercetti) #11

你甚至可以装一个dpkg之后下debian的包再用dpkg -i codeblocks.deb安装
如果出现依赖问题,确认装好opensuse版本依赖后再强行安装
估计问题不大

(xzhao) #12

直接使用alien的RPM或者DEB还是有一定问题的,有的依赖可能在openSUSE里面找不到对应的包,或者一些post install script得不到很好的执行,也没有办法进行包的版本升级维护。总之是有得有失吧,看每个人的具体需求。 @tommyvct

1赞
#13

谢谢你的建议,我会考虑的。

#14

行,我找时间测试看看。