openSUSE 15.2 安装 opensuse_zh 的 wps,提示缺少依赖

15.2,kde 加了 opensuse_zh 源,安装 wps 时提示缺少 libcdio19,libffi8 依赖,不知道该怎么解决?


啊这

对啊,就是这样所以才提问呢

感觉只有等苏姐去更新依赖。 @marguerite

LibreOffice 不好么?

我看看把依赖做成下载后首次运行时安装吧…现在 TW 跟 Leap 库的 soname 不一样。

临时解决方案就是安装 libcdio8 和 libffi7,然后忽略依赖安装 wps-office

我之前遇到这个情况,去官网下的 rpm 直接安装,并没有依赖问题,而且软件没有大的运行问题。
至于问为什么用 WPS 而不是 LibreOffice,如果你的工作/学习环境里绝大多数人都在用 MS Office,而你又想要一个不需要 Wine 的环境,那你只能选择 WPS.

请问一下,我也是从官网下载 rpm 安装,但是也安装失败了,图形界面跟命令行都试过了,命令行提示软件有签名。

提示有签名救跳过,或者点继续安装

1赞

谢谢,已经成功安装了。

更新最新版本后,运行:

/usr/bin/wps-office-installer -r -d=/usr/share/wps-office

会得到运行需要的所有依赖。这些依赖取决于你的操作系统版本,也就是说 Leap 和 Tumbleweed 得到的名字会不同。然后 zypper 安装即可。

另外我去除了这个软件包的所有运行时依赖。运行出问题需要先运行以上命令检查依赖关系。

1赞