Fcitx 5.0.0 已经发布

是否有可能更新后将 M17N/fcit5 系列包推送至 Tumbleweed?

昨晚上我也收到邮件了…活久见

消息总是来得这么突然

正式发布?

对,正式发布。

M17N 里已经更新完毕。检查一下 Obsoletes/Provides 后准备正式替换 Tumbleweed 里的 fcitx 4.x.x 系列。同时 Leap 里的 fcitx 4.x.x 正式进入 maintenance 模式。

2赞

求 Leap 15.2 安装 fcitx5 的方法。。。直接使用 Tumbleweed 源里的,貌似提示/usr/bin/bash 依赖错误,还缺少 boost 相关的依赖。。。

@wacke 加 M17N 源啊

呃,M17N 上刚更新的 5.01 编译 n 多报错,我前几天就开始偷偷 branch 过来尝试过,报错太多了。。。

@wacke 再等等我修修 Leap 15.2 back compability 吧

嗯嗯,谢谢学姐先。。。

15.2 的 obs,libme 依赖 libboost-regex,另外默认的 gettext 包不行,gcc7 包则不支持 #include filesystem。。。。我自己折腾了几天了。。。。

emm,fcitx5 的 kcm 配置面板是哪个包?

@Phage fcitx5-configtools

请问 Tumbleweed 的 fcitx4 该如何升级/替换为 fcitx5(新手,怕设置错)

直接删除 fcitx 的所有包后安装 fcitx5, fcitx5-configtool, fcitx5-gtk3, fcitx5-qt5 应该就可以了。另外你用 fcitx5-rime 的话还要装 fcitx5-rime,rime 的配置文件现在放在~/.local/share/fcitx5/rime 里面了。

1赞

是 zypper 安装后直接就可以用了(在 qt-creator,eclipse 内使用),还是要设置一下才能用?比如.xprofile
目前测试中有什么应用无法使用 fcitx5 吗?

添加 M17N 源,安装 fcitx5, fcitx5-chinese-addons,fcitx5-configtool 就行,会提示你和 fcitx4.2.9 冲突问你要不要替换。
昨天试了试应该没发现有不能用的,不过好像没找到怎么改输入法状态分别跟随不同程序。

我不用设置(我用 X,不清楚 Wayland 是不是需要额外的设置),我没有发现什么应用不能使用 fcitx5。

了解了,谢谢告知