WPS 在风滚草 KDE 桌面环境下很不稳定

加载一个普通的 Word 文档都要好几分钟,动不动就崩溃

不建議裝 WPS,它會把你的文件屬性改得亂七八糟的,圖標全換

这个不是发行版的问题,我在哪用都卡,这个是 WPS 或者往大说是 Office 文档的问题。所以,只要不需要我排版,能用 txt 就不会用 Word。

但是工作中难免会遇到 Word 文档批注的问题,总不能给人发个 PDF,对方不好修改。反馈文件中会有大量的批注,libreoffice 没有 wps 支持的好。

我的解决办法就是,依赖云文档,反馈文件我都是上传到云平台,本地系统就是接收和发送用,顺便作为离线存储备份,哪天平台没了,我写的东西不至于全丢。而且这样格式不会乱,批注正常显示,还能用 fcitx5+rime,哈哈。

但还需要备一个 Win 虚拟机,以供不时之需。

对了,还有个好处就是挑个趁手的浏览器就行了。

确实是,默认的 PDF 阅读器被改成 WPS 了

我的应用都比较简单,就是自己编辑,我感觉是 wps 和 KDE 或者 dolphin 工作不协调的锅。

我刚前几天想的办法是,安装 pcmanfm-qt 文件管理器,然后再 KDE 设置中指定它为默认的文件管理器,这几天没有问题。

现在 Linux 下可用的文档处理程序没几个,libreOffice 在排版和表格支持上与 Office 兼容确实不太好(不是说它不好),所以 wps 目前还是最优选择,而且我电脑上的 wps 在 Linux 比在 win 跑的更快(win 下是个人免费版,有广告等多余组件)。至于改默认应用程序,我没碰到,自己再改回来就可以了。

要不要在命令行运行,看看崩溃的是什么,或溯源。大家好避坑和报 bug。

home:opensuse_zh 源的 wps-office 现在默认不写死依赖。因为 Leap 和 Tumbleweed 的依赖不一样。你需要装好后运行下:

sudo wps-office-installer -r

列出 runtime dependencies 然后自己安装。你应该是装完就开箱即用了…

我试试看,之前都是直接安装的官网的 rpm

怎么在命令行运行?在命令行运行也是直接显示 WPS 窗口

我是在官网上下载的 rpm,很稳定。只是吐槽 WPS 界面不会融合到系统的暗黑主题当中,亮瞎。

那是因为 WPS 还在用 Qt4 。

3赞

Libreoffice 的排版和 WPS、Office 兼容很差,你不知道你报上去的文件人家打开是什么效果,日常编辑没法用

如果取消 “对齐到网络”,设置好字体映射表,用好换行分页符,基本上能做到显示效果一致。

如果是 x86_64, 用 flathub 的 onlyoffice, 再解决一下字体问题, 兼容性好过 libreoffice.

有空试试。根据我之前的经验,用 Office 打开 LibreOffice 编辑的文档没啥问题,但是用 LibreOffice 打开 Office 编辑的文档效果不好,速度也慢,特别是存在大量公式的时候。

这是微软故意使坏,他不是按标准 OOXML 保存的,LibreOffice 按标准 OOXML 解析能不出错就怪了。

哎,邪恶的商业帝国,自己搞的标准却不好好遵守

这算是常规的商业行为,很多商业公司都多多少少会搞点不兼容的私有标准。

都是利益驱动,谈不上邪不邪恶。毕竟资本驱动的东西没有善恶……

没有那么极端吧,其实 libreoffice 也是主要由资本驱动开发的 :dollar:

现在 libreoffice 70%+ 的代码,来自拿工资开发的 30 几个人,而且几乎都来自 Collabora。如果这家公司经营不下去,我们手中的 libreoffice 就要进入 openoffice 和 abiword 那样的养老状态了。


细节 -> https://lwn.net/Articles/825602/
https://blog.documentfoundation.org/blog/2021/02/03/libreoffice-7-1-community

一些讨论

https://news.ycombinator.com/item?id=23793942
https://news.ycombinator.com/item?id=23789659

2赞

Collabora 有部分开发者来自 SUSE 的 Libreoffice 团队。

1赞