打算入手 Yoga14s 2021 锐龙版,如何正确驱动 R7 5800H 的核芯显卡呢

大概猜到是 Linux 内核和固件的版本问题,R7 5800H 上的 Vega8 至少应该用什么版本呢

2000H 系列的 Vega8 在 15.1 已经可以直接使用了,AMD 的 CPU 与 GPU 驱动是分开的。但我还是建议你装 TW 或者用 Live 镜像试一下。

这个本我等了好久都没货……

讲道理,都祖传 VEGA8 了,会有个锤子显卡驱动问题哦,倒不如担心一下传感器驱动,和其他外围驱动。

产能问题年中才能缓解……
M$ 对此比较乐观,XBOX 的芯片供应 4 月份差不多能解决。
由于大法和 M$ 毕竟是 AMD 的亲爹,订单优先级会更高。
那么保守一点,大概 APU 的产能年中能解决。
DIY 产品则更延后。

从我之前使用 APU 的经验来看,旧有的 Vega 开源驱动并不一定适用于新的 APU。15.1 确实已经支持 R3 2200G 上的 Vega8 了,然而 R5 3500U 上的 vega8 在 Linux 内核 4.20 以上才可以使用,zen2 APU 上的 Vege8 只有 Linux 内核 5.6 以上才可以使用。如果你玩过 Gentoo 编译过内核的话,就应该知道不同 APU 上的 Vega 核显代号和驱动都是不同的。

没玩过,不了解这个。 :joy:我的意思是,AMD 的 CPU 驱动与核显驱动是分开的,二者的支持情况没有直接联系,所以我才建议他用 Live 镜像试一试

显卡驱动问题还真有,Vega 的核显据我所知 4.15 就进入内核了。但是之前 r7 4800H / r5 4600H 的 vega 核显,知道 Ubuntu20.04 的 5.4 内核也仍然不可以用