安装百度云盘客户端失败

系统:openSuSE Leap 15.2
已经安装了百度云盘客户端 3.3.2,下载最新的百度云盘客户端 3.5.0
安装提示
错误:INVALID:baidunetdisk-3.5.0-1.x86_64 (file-294d4cf3): 签名校验失败 [6-未签署文件]
Header SHA1 digest: OK
MD5 digest: OK
未签署包!
这个问题怎么破?

输入 i 来忽略此问题

签名校验失败忽略就好,烦人的是百度网盘识别不了 libuuid,忽略装上也不能用(我装的 TW),我用的还是论坛里某位大佬打包的 appimage。

** 网上有 deb 包,但不知道怎样转为 rpm 包来安装??Alien 经常实现不了包转换,不知道还有没有其它成功率高一点的包转换工具?**

2赞

你会长期维护这个软件包?

如果会的话,我打算在 openSUSE wiki 相关页面添加这个项目;是否需要标注实验性项目或其他提醒信息?

未找到 ‘baidunetdisk’ 的提供者。是出现什么错误了吗?

你添加了源了吗,还有是在什么发行版上安装的。

添加源了,在 openSUSE TW 版本安装的,昨天可能是网络不好,今天安装成功了,谢谢!

直接从 wps 官网下载的 wps Office 还是可以用的,但是更新的时候会导致和源里的冲突


如果选择更新,更新以后的 wps 打不开,没有任何的反应。不更新的话,老是有这个提示。我看您也在维护 wps,所以在这里问问您。

zypper al wps-office可以锁定 wps。从终端打开更新后的 wps 有报错信息吗?

没有任何报错信息,也不会打开 wps。

锁定以后就不会在有提示了,谢谢您!

感谢测试,我回去看一下,应该是少了什么依赖没有打包进去。

缺失了两个依赖,已经补上了。另外源地址改了,各个软件包分开存放,这样就不用给包加锁了。

我这边是忽略依赖强制安装的:
sudo rpm -ivh baidunetdiskXXXX.rpm --nodeps --force
安装就可以进行了,现在的 15.3 版本安装了启动不起来,参考下我的一些记录
opensuse 各种软件安装记录

1赞

fusionfuture 兄: nodejs-electron9 这个包, 在 leap15.3 中,依赖关系并不满足啊… 所以 baidunetdisk 也运行不起来…

~> baidunetdisk
electron9: error while loading shared libraries: libicui18n.so.70: cannot open shared object file: No such file or directory

ldd /usr/bin/electron9 | grep -i found

/usr/bin/electron9: /lib64/libc.so.6: version GLIBC_2.32' not found (required by /usr/bin/electron9) /usr/bin/electron9: /lib64/libc.so.6: version GLIBC_2.33’ not found (required by /usr/bin/electron9)
libicui18n.so.70 => not found
libicuuc.so.70 => not found
libevent-2.1.so.7 => not found
libvpx.so.7 => not found
libhttp_parser.so.2.9 => not found

先安装:sudo zypper in dpkg 然后直接安装 deb 包:sudo dpkg -i **.deb

为什么非要安装呢,直接解压缩用不好吗 :roll_eyes: