[ 已解决 ] 系统安装过程中,装载内核出现黑屏

使用 VMware Workstation 安装 openSUSE 13.1 时没有任何的问题。使用了有将近 1 个星期左右,觉得非常满意,今天将笔记本重装了。
使用 HP 450:
双显卡:1,Intel HD Graphics 4000 2,Radeon HD 7450M
从光盘安装。
装载内核提示条完后,

最后几个加载提示如下:
mount: /parts/01_usr: we need a loop device
mount: using /dev/loop1
2.048975] BIOS EDD facility V0.16 2004-Jun-25…

openSUSE installation program v4.1.5© 1996 -2012 <<<
starting udev…

然后就黑屏。。

按任何键都没有作用。

考虑到可能是双显卡的问题, 我在笔记本的 VGA 口再接一显示器,果然可以看到图形界面。

像我这种,连系统都还没有安装就黑屏的,应该如何来处理?

@torbai 这家伙能帮到你,他久病成医了。

来自 Galaxy Note 2 上的 Tapatalk 4

哎呀,系统还没装我也不知道该咋办

I + A 卡不至于呀。我还真不知道 AMD 的双显卡会有啥问题

BIOS 里可以选择禁用一个显卡吗?

笔记本自带的显示器始终黑屏吗?

使用外接显示器的时候显示的是正常的安装界面?此时自带的显示器上显示的是什么呢?
要是在 VGA 屏上能显示安装界面,我想可不可以激进点儿,直接连着 VGA 屏试着安装一下再说?

PS:@marguerite 姐姐,我可没成医呀呀呀。。。。。

BIOS 里面没有任何可供选择的开关,已经打了 HP 的 400 电话确认过了。
笔记本的屏幕在“starting udev…”后就一直黑着。
然后外接显示器,重新启动机器,笔记本屏幕会一直黑着,直到出现配置选择的时候,笔记本又开始有显示。(直接安装系统)
我安装完系统后,去掉外接显示器,系统启动后,一会就马上黑屏,不外接显示器就不给启动。
外接一个显示器,在进入 KDE 桌面环境的时候,笔记本又开始有显示。

不知道如何来处理了。

我觉得我是否应该先外接显示器,把系统给先装上。然后再去考虑换个显卡驱动的问题。
我应该参考哪些经验总结的贴子?
@Torbai:能否给些建议?

感谢!

@derick_1983

那你就外接装上吧,跟正常安装一样。别中间拔下来就行。

只有装上了才有 /var/log/Xorg.0.log 才能看发生了什么问题。

装上之后进入桌面后。关机。把外接拔下来,开机,肯定黑屏的,三五分钟之后再插回去,你应该有图形界面了。这时去看你的 /var/log/Xorg.0.log 然后把内容复制出来贴到 paste.opensuse.org

来自 Galaxy Note 2 上的 Tapatalk 4

1赞

这个不是黑屏吧,只是屏幕的背光没有了,但是屏幕还是有信息的
有尝试过用笔记本键盘上的 fn 组合键来调屏幕亮度么?
我的 ACER E1-471G i 卡和 GT620m 的组合,也是 starting udev 就黑屏,通过笔记本键盘上的 fn 组合键调节亮度就可以看到屏幕有内容显示了
或者在启动参数那里 加上 acpi_backlight=vendor 看看能行不
ps: 我的笔记本电脑内核只要 >= 3.7 就会在 starting udev 后黑屏(默认设置),现在都是在启动参数那里加上 acpi_backlight=vendor(代价是 fn 组合键没法调亮度了)

1赞

有可能

我想是不是 BIOS 出了什么错误导致的,需要初始化 BIOS
[ 已解决 /bios 问题 ] 联想笔记本,无线网无法使用,显示“被硬件禁用” 这个帖子里说过一种奇特的硬件问题(不过是网卡的),初始化了 BIOS 就好了。这次是不是也需要初始化 BIOS?

1赞

玛丽学姐,这个问题与我刚入 opensuse 时一样,估计原因还是 i 卡驱动有 bug,虽然后来 opensuse12.2 出更新修了这个 bug,但有可能这个补丁没进内核。使得又出现这个问题。
你可以尝试只用 a 卡,然后看日志,找一下将黑屏时是否出现关于 i 卡驱动的错误,或者只开 I 卡,一旦开机黑屏就重启,如果只需重启两次以内就能不黑屏,那就是我原来的问题。
ps: 我的本本现在没升,你一讲我又怕起来了。。。
等下我把那时的讨论帖链接上来。。。

Sent from my SCH-I699 using Xparent Skyblue Tapatalk 2

forums.opensuse.org/aeae-chinese/aesaeoeeeaezaeaeoe/acaezaeaeoe/482210-caeisaasaeaeoeaezaaeczea.html

Sent from my SCH-I699 using Xparent Skyblue Tapatalk 2

非常感谢大家的帮助,明天回到公司再试试,谢谢。

感谢你,确实是这个问题, 我通过笔记本的组合键确实可以看到屏幕了。

感谢各位的回复。感谢:marguerite、torbai、493409339、berryboy2012。你们的回复对我非常有用。

这个问题解决了,如@493409339 所说,通过笔记本的组合键调整屏幕的亮度就看到了。

现在感觉发热有点大,先把系统给安装完,再寻求解决办法了。

:joy: 以前不知道在哪里查到过这个启动参数 video.use_bios_initial_backlight=0
这个因为比较长,没记住也没试过,今天看贴吧的时候看到这个参数
我试了一下,开机 starting udev 之后不会黑屏,进入系统之后也可以用组合键调亮度