gdm无法启动怎么办啊?


#21

使用这个命令启动的是sddm


#22

顺便说一下,我把默认桌面设置成gnome,结果开机默认启动还是kde


#23

还有个 Windows manager DEFAULT_WM 可以设置


#24

是不是开启自动登陆了?


#25

我设置了,结果没有用


#26

是啊,是自动登录


#27

难怪,一开始我们都不会考虑这个方面。没想到你还真是自动登陆了。解决办法就是禁用自动登陆,然后,在登陆界面会有个选项,让你选择桌面。你选择gnome登陆一次,然后再试试自动登陆,看看什么情况。


#28

你为什么要折腾13.2?


#29

嗯,有效果了,不过gdm还是没用


#30

我是42.3,哪来的13.2?


#31

能进gnome就行,进去就直接把kde卸载了。多折腾,别怕事。


#32

Leap 上还在用 GNOME 3.14……


#33

是3.20,gdm版本是3.14


#34

我试试,我只想换成gdm,我也不怕折腾


#35

我勒个去,成功了,居然要把sddm给卸载了才有用!!!!!!!


#36

你这openSUSE怎么默认的是sddm?


#37

KDE 现在默认就是 sddm


#38

另外解释下,之所以要卸载 sddm 才行,是因为 sddm 最早不是 openSUSE 默认的几个启动之一(比如 GNOME 的 gdm,KDE 的 kdm),所以在开发改 sysconfig 机制的时候没有算它。openSUSE 这个机制有了之后很久,我都已经用 openSUSE
好几年之后它才出现,当时它是以独立的启动器的身份存在的,加上出现的比较晚,所以它有自己的 systemd service…

于是楼主面临的情况其实是 ssdm.service 正在运行,所以就运行不了 xdm.service (指向 gdm)。

比较合理的做法是

sudo systemctl stop sddm.service
sudo systemctl disable sddm.service
sudo systemctl enable xdm.service
sudo systemctl start xdm.service

或者在做完前三条之后重启。

目前看,把 sddm.service 删除掉用 openSUSE 的现有机制有点开历史的倒车,所以最好的方式应该是把 openSUSE 的那几个 DM 都给写出 systemd service 来,然后把老机制迁移到不使用链接而对应去 enable/disable 相应的服务。


#39

如果照上面几个命令,要换回来sddm咋办???把xdm给disable了再enable?感觉好蒙圈啊。
我觉得manjaro做的还不错,不用禁用旧的dm,直接enable新的dm service
写个service就要换个机制,service好写,要应用到广大opensuse用户就比较难了,也希望能快点解决这个问题


#40

对,就是把 xdm disable 了然后把 sddm enable 了。这没什么蒙圈的,systemd 的 service 就是这么管理的。你把 xdm 视同为 gdm 就可以了。

不禁用旧的 dm 就 enable 新的 dm,的后果就是两个都启动不来。你可以在 manjaro 下 systemd status -l 那个旧的 DM 的 service 看一下。我回头也找两个 manjaro 的 DM 服务来确认一下。

其实不换机制也行,但那样老机制就直接淘汰了,在 YaST 里就改不了了,对新人更加的不友好。