hdparm的M选项失败


#1

如题:机器是笔记本 ASUS老本。双硬盘,系统42.3。其中ssd在主硬盘上。安装了/分区。其他都在光驱位置上的机械硬盘上。分了/var /opt /home 等等。硬盘在开机状态下机械盘不停的响。然后>sudo hdparm -S 120 了/ var opt /home发现还是不停的响。
刚才用hdparm 的 -M 128选项试了一下看提示说不行。不知道是不是不支持还是怎么滴呢?

SUSE:~ # hdparm -M 128 /dev/sdb3 

/dev/sdb3:
setting acoustic management to 128
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 04 51 40 80 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
acoustic      = not supported
SUSE:~ # hdparm -M 128 /dev/sdb4

/dev/sdb4:
setting acoustic management to 128
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 04 51 40 80 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
acoustic      = not supported
SUSE:~ # hdparm -M 128 /dev/sdb5

/dev/sdb5:
setting acoustic management to 128
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 04 51 40 80 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
acoustic      = not supported

网上找了一下也没看到靠谱的说法:
http://lkml.iu.edu/hypermail/linux/kernel/0806.2/2157.html


#2

是这个问题吗?
https://forums.linuxmint.com/viewtopic.php?t=124302


#3

差不多就是把 我刚才找了一下 还不是很却定是不是西部数据的硬盘也不支持这个功能呢


#4

首先你对分区操作不是很明白什么意思,/dev/sdb是你机械盘直接指定/dev/sdb就是了。
还有,说明一下“不停的响”具体指什么?机械硬盘运行肯定不会没有声音,你指的是磁盘只要空闲几秒钟,磁头就马上回缩,咔的一声?那个是WD的IntelliPark在作怪,安装gsmartcontrol看一下你机械硬盘的SMART数据,0xC1数据大于一万肯定是这个问题。如果是的话,去WD网站下载WDIDLE3.exe,去纯DOS下(FreeDOS就可以用)执行WDIDLE3.exe /D就可以禁用那个功能。


#5

不明白你所说的分区操作具体指的是什么,我上面代码已经贴上去了。另外你说的这个“直接指定/dev/sdb”已经试过了。所谓的不停的响就是硬盘不停的在运转中发出来的声响 没有“咔”的一声。昨天搜了一下相关方面的资料 目前还不是很确定是不是这个硬盘不支持hdparm的命令操作。
另外你提供的方法是win系统下的可执行文件。我的系统是openSUSE.


#6

sdb3, sdb4, sdb5指定的是硬盘上的分区,不是硬盘本身;你需要设置的AAM是针对硬盘硬件的,而不是软件上的分区。你没有仔细看完就回复,我已经说了那是DOS下的可执行文件,必须要去DOS底下执行,但既然不是IntelliPark在作怪,这都不重要了。

重要的是你把/home什么的放在机械盘上,你还指望机械盘休眠,我不明白这是什么逻辑。你难道指望OS完全不访问/home,/opt和/var?你想让硬盘经常休眠的话,关键分区一个都不能放在上面,不然你AAM/APM怎么设置都不会有用的。


#7

感谢你的回复 我在官方网站找到了系统管理硬盘的软件“laptop-mode-tools”
链接:https://zh.opensuse.org/%E7%A1%AC%E7%9B%98_APM_%E8%AE%BE%E7%BD%AE
看了一下我的:
二 2月 13|21:45|0:>systemctl list-unit-files | grep "laptop*"
laptop-mode.service disabled
没有默认像官方页面说的是开机启动所以这个要手动设置开机启动
另外配置文件里面支持hdparm选项 也需要自己开启
现在试试再说
另外给wd打了400电话 给我的回复和你第一次回帖差不多 给个测试软件让我回到win系统测试
回去测试前两项没发现问题 我咩有其他硬盘 无法备份现有数据所以清零的测试没有执行


#8

设置了laptop-mode.service开机启动
修改配置文件laptop-mode.conf启用了hdparm 和cpufreq
发现APM_level=254了
手动修改重启会失效 不知道具体原因


#9

修改如下三个文件都是128之后
二 2月 13|22:43|0:>cat -n /etc/laptop-mode/laptop-mode.conf | grep "128"
317 BATT_HD_POWERMGMT=128
318 LM_AC_HD_POWERMGMT=128
319 NOLM_AC_HD_POWERMGMT=128

二 2月 13|22:43|0:>sudo hdparm -B /dev/sdb

/dev/sdb:
APM_level = 128