有没有tumbleweed的nvidia国内源


#1

如题,谢谢!


#2

没有。TW 从来没有过 Nvidia 源。


#3

苏姐说的不完全对。
这里有一个国外源,但是不保证能完美跟上kernel版本更新。也就是说,不会每次TW内核更新它都会对应更新。也就是说,可能出现TW内核更新而Nvidia内核模块不能编译的情况。
http://download.nvidia.com/opensuse/tumbleweed/x86_64/
如果使用,建议写个脚本,升级时检查此repo中kmp包里面kernel版本,只有一致才更新kernel和nvidia闭源驱动。
相关新闻:https://www.phoronix.com/scan.php?page=news_item&px=Tumbleweed-NVIDIA-Driver


#4

实际上,不单单是Nvidia,很多openSUSE的国内镜像源都不稳定。
Tumbleweed 是滚动发行版,需要每天向根服务器拉最新的更新,需要更新mirror list(https://mirrors.opensuse.org/),leap也需要经常升级。但是很多镜像都不太爱管,openSUSE这边联系对方也都是石沉大海,也不解释原因,也不说有什么openSUSE这边可以做的。所以没有办法,毕竟镜像服务器是人家的财产。
所以您有什么需要呢,还是尽量从openSUSE的服务器上拉,但我承认速度确实不快,现在只能这样。

另外,我自己平时不用Nvidia或AMD的驱动,因为有他很多技术问题和Bug,开源驱动不是很好用嘛。:slight_smile:


#5

开源驱动支持3D加速吗?


#6

大多数支持,不过取决于你的Nvidia显卡型号,参见nouveau feature matrix:
https://nouveau.freedesktop.org/wiki/FeatureMatrix/


#7

我的显卡是gtx 1070,想让nouveau 支持VMware 3D加速,需要下载什么软件包吗


#8

您是linux虚拟机用vmware虚拟化运行在windows上面吗?物理主机的显卡是gtx1070?
如果这样的话,那是你现在需要解决vmware虚拟出来的显卡是否支持硬件加速的问题。linux上需要加载对应vmare虚拟显卡的驱动,不应该再使用nouveau。也不需要装什么包了呀。


#9

我的主机是Linux,虚拟机是windows ,正相反


#10

有答案了,去试一下


#11

如果要用win的话 还是用显卡直通吧(fuck NVIDIA 如果非要在linux下跑图形项目就当我没说)
毕竟1070
而且你用风滚草闭源驱动想不滚挂还是洗洗睡(wiki就是这么说的)主板有双卡槽的话开vt-d/IOMMU 应该会更爽
只是要买张能跑一部分3d加速的亮机卡


#12

KVM不挺好吗?