Wine不响应系统的字体设置,无法开启反锯齿


#1

系统的字体设置里已开启了反锯齿,但是 wine 并不识别系统设置。正好硬盘上还有一个空的分区,全新安装了一个 Mint 测试了一下,发现 Mint 里的 wine 对系统的字体设置是响应的。openSUSE 里和 wine 里都安装了 Tahoma 字体,然而打开 winecfg,文字依然是有锯齿的。

试过很多的方案,都没法开启反锯齿功能,经过这些尝试以及在 Mint 下的一些测试对比,猜想应该与 openSUSE 或者 openSUSE 下的 wine 包有关,然而新手不知该怎么反馈这个问题。故来此求助。




已尝试过的方案:
1. . winetricks allfonts gdiplus riched20 riched30
2. . 修改注册表键值:通过 winetricks fontsmooth=rgb(显示器的子像素排列确认过是 rgb 的,实际上另外两个 winetricks fontsmooth=* 也试过了,都没效果。另外 Mint 下测试的结果是这些 fontsmooth 选项的切换不影响 wine 运行的程序。)
3. . 添加注册表键值:
*
* [HKEY_CURRENT_USER\Software\Wine\X11 Driver]
* “ClientSideWithRender”=“Y”
*
* 上述最早是在 这里 ](http://wp.xin.at/archives/2499) 看见的
* 后来用上述关键词反向搜索在 wine 的 wiki 上查到了 X11 Driver 下还有另外两个键值可以修改:
*
* ±>ClientSideWithRender
* | [Set this to “N” if you don’t want to use the Render extension to render client side fonts]
* |
* ±>ClientSideAntiAliasWithRender
* | [Set this to “N” to disable font anti-aliasing when X-Render extension is present]
* |
* ±>ClientSideAntiAliasWithCore
* | [Set this to “N” to disable font anti-aliasing when X-Render extension is not present
* | or disabled]
*
* 尝试之后依然没有任何效果。
22. . 在 wine 官方的 IRC 求助过,然而给出的办法没有超出上述的。

openSUSE 版本:openSUSE-Leap-42.1-DVD-x86_64.iso,全新安装。
桌面环境是默认的 KDE,同时也安装了 Xfce 环境进行测试,结果都是 wine 不响应系统的字体设置,所以猜测与桌面环境无关。
openSUSE 下的 wine 是 1.7.52。

Linux Mint 版本:linuxmint-17.3-cinnamon-64bit.iso,全新安装。
Mint 下测试了默认软件源里的 wine-1.6.2 和 第三方源 Wine Team PPA](https://launchpad.net/~ubuntu-wine/+archive/ubuntu/ppa) 里的 wine-1.8,均可响应系统配置。


#2

你选错了字体,文泉驿正黑内嵌有点阵字体,字号小于 14 时会被自动激活。点阵字体是不支持反锯齿,不管你怎么设置都没用。所以要么把字体字号调整为 14 以上,要么设置为其他矢量字体,比如文泉驿微米黑。



#3

啊回复好快@_@

不过从截图看,您那边的 wine 字体渲染也不太正常。
这是别的发行版下的结果。这个反锯齿算是比较正常的了。


不过也还是有一点小问题,wine 对 hinting 的使用并不与系统设置的一致:wine 里使用了重 hinting(openSUSE/Linu Mint/Ubuntu,默认的都是 slight hinting),无论系统怎么改,wine 下的程序都没有改变。
从对 Tahoma 的渲染可以看出来,比如下图(其实这个是今天才发现的,今早在 Mint 下把 KDE/Mate/Cinnamon 三个桌面环境都试了一遍,结果发现还是有问题啊 T_T)


#4

同样还是点阵字体的原因。因为我安装有 Windows 的新宋体,这货是个点阵字体,反锯齿对他无效,所以我这里 wine 的菜单没有反锯齿效果。目测你可能也是安装有新宋体。

来自我的 Nexus 7 上的 Tapatalk


#5

原来都是这样呀,还以为就我是特例呢。不过 wine 的程序,也就是将就用了。

发现 openSUSE 默认还是使用文泉驿字体的。前几天在 YAST 里面安装了文泉驿微米黑,发现默认字体不是思源黑体了。不过看起来还好,就没改。

使用中发现文泉驿微米黑有不少问题。比如数字“5”,前后距离就不对。还有一些中文字体不在一个基准线上。